Joomla: napaka »Database Error: Unable to connect to the database:Could not connect to MySQL«
Joomla uporablja zbirko podatkov. Če povezave z zbirko podatkov iz nekega razloga ni mogoče vzpostaviti, lahko dobite to sporočilo:
Database Error: Unable to connect to the database:Could not connect to MySQL
V datoteki configuration.php (ta je v mapi, kjer je nameščena Joomla) najdete te nastavitve za povezavo z zbirko podatkov:
var $host = 'localhost'; // To je vedno localhost
var $user = 'XXX_ZZZ'; // XXX je ime uporabnika nadzorne plošče, ZZZ je uporabnik zbirke podatkov
var $db = 'XXX_YYY'; // XXX je ime uporabnika nadzorne plošče, YYY je ime zbirke podatkov
var $password = 'wachtwoord'; // Geslo, ki ste ga dodelili uporabniku zbirke podatkov
Če povezave ne morete vzpostaviti, je morda kaj narobe z zgornjimi podatki.
Prijavite se v nadzorno ploščo in izberite meni MySQL. Nato izberite zbirko podatkov Joomle (kliknite jo), kjer so prikazani obstoječi uporabniki zbirke podatkov. Po potrebi ustvarite novega uporabnika zbirke podatkov ter njegovo uporabniško ime in geslo vnesite v configuration.php. Če uporabnik zbirke podatkov že obstaja, mu za vsak primer spremenite geslo, da se bo ujemalo s tistim v configuration.php.
Če ste Joomlo namestili prek Installatrona, lahko ime zbirke podatkov poiščete tudi v Installatronu.
